Article overview:

  1. Google Chrome

  2. Safari

  3. Firefox

  4. Internet Explorer


When encountering bugs on Filestage, it can be challenging for our developers to pinpoint the issue from a distance due to the potential presence of local factors. To help our team diagnose the bug, we may ask you to generate an HTTP archive (HAR) file. This file displays the redirections during a login transaction and is a helpful tool for identifying authentication problems. In case authentication is not functioning correctly, analyzing a HAR file can help locate the source of the issue. Including the file in your support requests can expedite the troubleshooting process.


How to generate a HAR-File within your browser?

Google Chrome

  1. Close all incognito windows in Google Chrome.

  2. Open a new incognito window in Google Chrome.

  3. Go to More Tools > Developers Tools.

  4. In the Developer Tools pane, choose the Network tab.

  5. Check the Preserve Log checkbox to record all interactions.

  6. Visit the page and complete the steps that trigger the issue.

  7. Choose the Network tab.

  8. Click the down arrow to export the HAR file.

  9. Save the HAR file.


Safari

  1. Ensure that Show Develop menu in menu bar checkbox is checked under Safari > Preferences > Advanced.

  2. Choose File > Open New Private Window.

  3. Visit the web page where the issue occurs.

  4. Choose Develop > Show Web Inspector. The Web Inspector window appears.

  5. Complete the steps on the page that trigger the issue.

  6. Select the Network tab.

  7. Click Export on the upper right side of the pane.

  8. Save the HAR file.


Firefox

  1. Close all private windows in Firefox.

  2. Open a new private window in Firefox.

  3. Go to Tools > Developer > Network or ctrl-shift-E.

  4. Visit the page and complete the steps that trigger the issue.

  5. Choose the Network tab and right-click and then select Save All As Har.

  6. Save the HAR file.


Internet Explorer

  1. Close all InPrivate windows in Internet Explorer.

  2. Open a new InPrivate window in Internet Explorer (ctrl-shift-P.)

  3. Go to Tools > F12 Developer Options > Network.

  4. Ensure Clear entries on navigate is switched off.

  5. Visit the page and complete the steps that trigger the issue.

  6. Choose the Network tab and select Export as HAR (Ctrl+S).

  7. Save the HAR file.


💡 What's next? After creating a HAR-file, see how to contact our customer support to help diagnose an issue. How can I reach out to the customer support?


If you have any questions or comments, feel free to start a chat or email us at support@filestage.io. We’re always happy to help.

Did this answer your question?