Wenn Bugs in Filestage auftreten, ist es für unsere Entwickler manchmal schwierig, Prozesse aus der Ferne schnell zu identifizieren, da oft viele einzelne lokale Faktoren involviert sind. Wenn du mit einem Bug konfrontiert wirst, bitten wir dich hin und wieder, unsere Entwickler bei der Diagnose des Problems zu unterstützen, indem du eine HAR-Datei erstellst.

Eine HAR-Datei (HTTP-Archiv) zeigt die Reihenfolge der Umleitungen, die während einer Login-Transaktion auftreten. Sie ist ein ausgezeichnetes Werkzeug zur Fehlerbehebung bei Authentifizierungsproblemen, da sie erkennen kann, wo Dinge festhängen. Eine HAR-Datei ist ein JSON-formatiertes Protokoll der Interaktionen eines Web-Browsers mit einem Web-Server. Wenn die Authentifizierung nicht wie erwartet funktioniert, kannst du HAR-Dateien generieren und analysieren, um Probleme zu finden. Das Einfügen einer HAR-Datei in deiner Support-Anfragen kann die Fehlerbehebung beschleunigen.

Wie erzeugt man eine HAR-Datei im Browser?

Google Chrome

  1. Schließe alle Inkognito-Fenster in Google Chrome.

  2. Öffnen ein neues Inkognito-Fenster in Google Chrome.

  3. Klicke in der Menüleiste von Chrome auf Anzeigen > Entwickler > Entwicklertools.

  4. Wähle im geöffneten Fenster die Registerkarte Netzwerk.

  5. Aktiviere das Kontrollkästchen Protokolldateien aufbewahren, um alle Interaktionen aufzuzeichnen.

  6. Besuche nun die Seite wo der Bug vorkommt und führe die Schritte aus, die das Problem auslösen.

  7. Wähle erneut die Registerkarte Netzwerk.

  8. Klicke auf den Abwärtspfeil, um die HAR-Datei zu exportieren.

  9. Sicher die HAR-Datei auf deinem Computer.

Safari

  1. Vergewissere dich, dass das Kontrollkästchen Entwickeln und wähle Webprüfung anzeigen unter Safari > Einstellungen > Erweitert aktiviert ist.

  2. Wähle Datei > Neues privates Fenster öffnen.

  3. Besuche die Webseite, auf der das Problem auftritt.

  4. Wähle Entwickeln > Web-Inspektor anzeigen. Das Fenster Web-Inspektor wird angezeigt.

  5. Führe die Schritte auf der Seite aus, die das Problem auslösen.

  6. Wähle die Registerkarte Netzwerk.

  7. Klicke oben rechts im Fenster auf Export.

  8. Speicher die HAR-Datei.

Firefox

  1. Schließe alle privaten Fenster in Firefox.

  2. Öffne  ein neues privates Fenster in Firefox.

  3. Gehe zu Tools > Entwickler > Netzwerk oder ctrl-shift-E.

  4. Besuche die Seite und führe die Schritte aus, die das Problem auslösen.

  5. Wähle die Registerkarte Netzwerk, klicke mit der rechten Maustaste und wähle dann Alle als Har speichern.

  6. Speicher die HAR-Datei.

Internet Explorer

  1. Schließe alle InPrivate-Fenster in Internet Explorer.

  2. Öffne ein neues InPrivate-Fenster in Internet Explorer (Strg-Shift-P).

  3. Gehe zu Extras > F12 Entwickleroptionen > Netzwerk.

  4. Stelle sicher, dass Clear entries on navigate ausgeschaltet ist.

  5. Besuche die Seite und führe die Schritte aus, die das Problem auslösen.

  6. Wähle die Registerkarte Netzwerk und wähle Speichern (Strg+S).

  7. Sicher die HAR-Datei auf deinem Computer.

Ähnliche Artikel:

Wenn du Fragen oder Anmerkungen hast, kannst du gerne mit uns chatten oder uns eine E-Mail schicken an support@filestage.io. Wir helfen dir gerne weiter.

War diese Antwort hilfreich für dich?